Smok Majesty won't power on


#1

Like the title says my smok majesty refuses to actually power on. If I open, wait a few moments, the close the battery door the smok splash screen will show but pressing the fire button 5x does absolutely nothing apparently.

If I plug in the usb to a external charger it’ll pop up the battery charge screen but as soon as I unplug it and try to turn it on nothing.

It doesn’t fire the tank (nor would it after all the times I’ve removed the batteries it’s definitely off) so I know it’s not in any sort of stealth mode it just won’t turn tf on. I have no clue why I’ve tried 4 different batteries all 18650 3500mAh 20A batteries fully charged they all will show the smok splash but the mod won’t turn on.

Only thing I can think of is somehow the firing button broke internally? Wouldn’t make any sense as I’ve never dropped it and the worst abuse it’s seen is shaking in the cup holder of my truck. Anybody experienced similar problems?

I knew getting a electronic mod would be a mistake. My mech has literally fallen out of my truck on the freeway before and all I had to replace was the plunger. This thing shits the bed mid vape being held carefully.


#2

Hello! It may be that your device is actually in stealth mode but your firing bar/screen is also “locked” hence why it’ll turn on when putting batteries in and when charging. If that’s not the case, may I ask how you are charging your batteries? If you are charging your batteries through the micro USB port on the device with the batteries still inside it could be that you have damaged the electronic board/chipset inside your device. When charging through micro USB you may overpower the device with too much current either from the USB cable, wall/charge block or even wall socket itself which will cause the chipset and fuse within the device to become damaged. It is always recommended to charge your batteries through an external bay charger such as the nitecore I2, D2, Efest luc v4 ect. Especially with higher powered 2+ external battery devices. Hope this helps! If you have any more questions please continue to post here or stop into a 180 smoke vape shop if you have the time and an associate will be more than happy to take a look at your device for you and answer any questions you may have.


#3

Nah it’s definitely not in stealth or locked after all the times I removed the batteries and re-installed them. I didn’t want to take it apart but I think the solder point or button to fire the mod broke internally because that’s the only thing that makes sense. Like I said if I put batteries in it the smok splash screen will pop up, if I plug it into a pc or external charger the battery charging screen pops up so to me that just leaves the power/fire button isn’t working for whatever reason.

And I use a nitecore dual charger and 4 mxjo 3500mAh 3.7v 20A batteries so I’m definitely not trying to actually charge those with the mod just wanted to be as specific as possible in case anyone else had a similar problem and could go “hey yeah that happened to me and how I fixed it was…”

Thanks anyhow


#4

Halo, I have the same problem but it is not a fire boton problem. I dissambled completely and probed it. It is a software problem. Soon I’m going to try intal a new software that I found from procolor. It nos the same mod but I think the electronic are de same. What else, could you prove plug with usb in your computer, in mine with windows 10 dont recognise it. (First remove the bateries and always keep de fire boton pulse)

Please if you do it contact with me. Sorry for my english

Thanks