SMOK Stick V8 Baby not charging

I bought the vape yesterday and it was working perfectly fine. I used it for some time and when I came back home I put it on charge to see if the battery is correct.
I took it out of the charger and went outside. When I came back I put it on charge and the red light doesn’t appear and when I try to hit it I sometimes get 4 or 15 blinks, help?

(i tried unscrewing it a bit, changing the tank, cleaned it and everything)

Have you turned the device on by clicking the button 5 times quickly?

Beyond that, you’ll want to make sure that the tank’s coil is properly installed. Otherwise, it might not recognize that there’s a coil in there.

1 Like

Yeah, I tried that. I can take a picture if you want, but I’m sure everything is nice and tight.

How about the charger? What are you charging it through (wall outlet block, computer, etc.)

1 Like

I tried charging it on a wall outlet, nothing. Now I’m trying to charge it via my computer and still nothing.

(And yes, I’m using the charger that I received in the box)

P.S. thank you for the quick response!

1 Like

Hmmm interesting… From my experience it sounds like it could be one of two issues:

  1. The device is not properly connecting to the charger, so the device is completely drained and not taking any power in, or

  2. The coil you’re using is, for some reason, not connecting to the battery.

I probably should have asked this earlier, but how long have you had this device? Have you replaced the coil recently?

1 Like

I literally bought it yesterday.
I was thinking of returning it and asking for a new one (with a warranty ofcourse)

Never changed the coil (didn’t look like I had to because I just bought it 20 hours ago)

If you just purchased it, it’s highly like that the battery is actually just turned off (even if it’s off, it will still flash whenever you take it off of the charger).

Try clicking the button 5 times really quickly and it should blink indicating that it’s turned on.

1 Like

Alright,
I turned it on, blinked 5 times. Put it on the charger, nothing’s happening. No red light on the back is indicating that it’s charging or anything. I’ll set it to charge for an hour and see what happens.

And still nothing. Around 20 minutes passed,

I think I’m just going to go to the shop that I bought the vape from and get a new one with warranty.

Yeah, if it’s still not working for you, it’s best to take it back to the shop you bought it from to get it looked at.

1 Like

will do that, thanks for your time :))

1 Like

No worries at all! Hopefully you can get yourself a working vape!

I just had the same problem. Apparently it was a bad coil. I changed the coil and it stopped charging. I made sure it was tight and everything as well. Something told me try another coil and I did so which fixed the problem

Just had the same issue was about to go replace my unit. Decided it was likely a coil issue looked at the bottom of the coil and the center plug on the bottom just needed to be realigned so the wire made proper contact. Didn’t even need to replace it

Same thing happened to me. Futzed around, changed the coil. Nothing. Read some posts, and I went back and LOOSENED the coil a bit. Worked like a charm!

If the light blinks continuous when plugged in it’s a inner battery problem smack it it works also to check take a blunt sharp pin stick it in small hole in bottom of vape
And gently push in till you feel resistance and light on battery blinks.it should work after that.remember if light is blinking when you plug in smack it light had to be steady lit to charge it.**

[quote=“mihael27, post:1, topic:1180, full:true”]
I bought the vape yesterday and it was working perfectly fine. I used it for some time and when I came back home I put it on charge to see if the battery is correct.
I took it out of the charger and went outside. When I came back I put it on charge and the red light doesn’t appear and when I try to hit it I sometimes get 4 or 15 blinks, help?

(i tried unscrewing it a bit, changing the tank, cleaned it and everything) In the

on bottom of battery light should flash norms in your TV to toon

Hey thanks to whomever posted about the Smok V8 Stick, pressing the button 5 times rapidly for saving me about 60 bucks and having a crappy Saturday. I thought my maybe 4 month old one was broken, but that’s all it was :slight_smile:!!!

Hey i am trying to find out if my vape stick is broken or what not. I have a smok v8 stick with a smok big baby beast top fill tank. Its about a little over a year old maby not too certain about that maby less. But anyways i put it away for a while for about 6 months give or take. Well a few days ago I noticed i was smokeing about 2 packs a day again. So I searched everywhere for my v8 stick well I found it. I then put it on charge. The red light on the back light up. I let it sit for 24 hours. I tried to turn it on hitting the button 5 times quickly. No blinks nothing. It won’t turn on. Does anyone know what or why.

This is a community discussion and help site for all Vapers and current Smokers considering a switch.Participation is encouraged and appreciated.

You must be at least the Age of Majority (19+ in Ontario) to use this website. All information, including from a member of 180 Smoke Staff, are not intended to replace professional medical advice and are based on personal experiences. Information and statements regarding these products have not been evaluated by Health Canada or the FDA. Please be responsible with e-liquid and vape devices, and keep them stored out of reach of children and pets—they can be fatal to them, even in small quantities!

Popular searches: Buffalo Vape Store, Wholesale eliquid, Vape Wholesale, vaporisateurs herbe, Vape News, e-liquid, e-cigarettes, Vaping, Weed Vape