SMOK Stick V8 kit not charging after replacing coil


#1

I have had my mod (SMOK Stick V8 kit) for over 3 months now and I just got it back from my boyfriend who I lent it to and switched the coil because he uses a higher mg of nicotine than I do and I went to plug it in on the charger ( the one I got in the box) when I finished switching to a new coil and the red light stays on for about 30 seconds indicating charging and then shuts off but the firing button still flashes when I try to fire. I’ve tried to take out then put the could back in about 4 times now and it’s still not charging or firing


#2

It could possibly be the battery that has an issue. Do you charge it overnight? Have you tried tightening your coil on the base?


#3

Try the above stated, also if you can bring it to a friend or store that has the same tank, see if it fires. If all fails try contacting smok directly , I hope you have kept the box because for aftercare and warranty it is very crucial.

Best of luck


#4

I used to charge it overnight about a month ago before I let him use it, and I’ve tried taking it apart off and on all yesterday, tightening it and redoing it.