Tpriv 3 smok not turning on


#1

I just bought a Tpriv 3 off a reliable friend. It worked really well, charged great, and she didnt have it for long, never stopped working for her. Recently it stopped working for me, it said i needed to charge battery, and they were charged, so i left them on the charger for the night and it started working again. Then it stopped, again. I charged my batteries the correct way, put the batteries in the correct spot and now it doesnt turn on. A friend plugged the android charger in to update it, and it didnt help anything. Im not sure what to do, i was looking through some of recent questions and i figured i want to ask if you or anyone can help me out, if not i will visit the vape shop i go to.


#2

@torigaddy Was there any response at all when you plugged it in to update the firmware? Was the device turning on at all? Are those batteries older or brand new?


#3

The batteries are new, and the mod would not show any sign of being on. It did not turn on or blink any lights.


#4

@torigaddy this may seem like a silly question, but I’ll ask it anyways – did you click the fire button 5 times to turn it on? It might have been turned off by accident (I’ve seen it happen quite a few times).


#5

Yes i tried clicking the hitting button five times, and even tried to hold it for five seconds to see if that would work, but nothing.


#6

@torigaddy Hmmm, in that case, it wouldn’t hurt to get it checked out at a vape shop. They should be able to assess the device and let you know if it’s something that can be troubleshot or if the device itself is dead.